1960 Raleigh to LED Lights

My 1960 Raleigh Superbe Roadster gets its lights upgraded to high power LEDs in the original housings.

So I have my dear, all-original 1960 Raleigh Superbe Roadster (I think that’s what it’s called).  It’s got a 4 speed internal-gear hub with a built-in generator in the hub.  The great thing is that on a bike this old, they still thought of having the generator charge a battery pack and then running the lights off that, so the lights would stay on even when stopped.

Whatever battery pack they had inside that cylinder was long gone, so I replaced it with 5x AA NmH batteries.  I took the thing apart and replaced the rectifier with a modern one (presumably more efficient and working). The battery holder fit quite neatly inside.

The rear LED is a 1W Cree Q5, that I just sort of cheated and put a resistor in-line to regulate it.  It all jammed into the tail unit ok, but in my excitement to get it to work, I didn’t bother mounting the LED on any heat sink and just relied on the stiffness of the wires to hold it in place.

After that, it was the front light.  I’m using a 3W Cree Q5 LED mounted on a section of M10 bolt that threads into the existing bulb mount.  The bolt has the head cut off and a hole drilled through the middle for the wires.  In the pictures, you can see that the LED is already mounted on a heatsink pad — that was then stuck to the end of the bolt with heatsink epoxy.  Unlike the tail lamp, I’m using a proper regulator for this LED.  The regulator is glued tto the inside body of the lamp housing with heatsink epoxy.

All of this is wired up to the switch and back to the battery pack.

2-Year Update:

I’ve made some slight cleanup of the wiring since then, but other than that, the lights have been working perfectly through commuting and nightly rides.  I still haven’t been able to figure out how long they’ll run with out without riding, but I haven’t had them die on me yet.  I’ve ridden for over 2 hours at night and still the lights don’t dim!  They do heat up a bit, especially the front one with its regulator heat sunk to the body, but everything seems to be ok!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: